Excel-Quickies (Vol 12) 7

Ein paar schnelle Tipps, die dir die Arbeit mit Excel erleichtern werden.
 

Du bist auf der Suche nach kurzen, knackigen Excel-Tipps? Ohne langes Herumgeschwafel? Dann sind meine Excel-Quickies vielleicht das Richtige für dich.

Einmal im Monat stelle ich unter dieser Rubrik ein paar kleine Kniffe vor, die dir dein Excel-Leben vereinfachen können.

Oder die du für einen etwaigen späteren Gebrauch einfach in deine Excel-Werkzeugkiste legen kannst.

Vorhang auf für die Excel-Quickies im Juni!

Im heutigen Beitrag zeige ich dir, wie du

  • eine Quersumme berechnest
  • Uhrzeiten auf Viertelstunden rundest
  • Zelleninhalte unsichtbar machst

Vielleicht ist auch für dich etwas dabei!

Excel-Quickie Nr. 46: Quersummen berechnen

Diese Funktion wirst du sicherlich nicht jeden Tag brauchen. Aber vielleicht kommst du ja doch mal in Verlegenheit, die Quersumme einer Zahl in Excel berechnen zu müssen. Mit dieser Matrix-Formel ist das kein Problem:

{=SUMME(1*TEIL(A2;ZEILE(INDIREKT("1:"&LÄNGE(A2)));1))}

Quersumme berechnen

Quersumme berechnen

Wichtig:
Da es sich um eine sogenannte Matrix-Formel handelt, dürfen die geschweiften Klammern nicht von Hand eingetippt werden, sondern man schließt die Eingabe mit der Tastenkombination Strg+Umschalt+Enter ab.

Excel-Quickie Nr. 47: Zeiten auf Viertelstunden runden

Da eine Zeiterfassung mit Excel durchaus in der Praxis vorkommt, ist der folgende Quickie vielleicht interessanter. Manchmal müssen keine exakten Uhrzeiten berechnet werden, sondern z.B. auf volle Viertelstunden gerundete Zeiten. Wie aber rundet man eine Uhrzeit?

Angenommen, in A2 steht die zu rundende Uhrzeit, dann lautet die Formel so:

=RUNDEN(A2*96;0)/96

Auf volle Viertelstunden runden

Auf volle Viertelstunden runden

Dahinter steckt die einfache Überlegung, dass ein Tag aus 24 * 4 = 96 Viertelstunden besteht. Um auf halbe Stunden zu runden, ersetzt man die Werte „96“ einfach durch „48“.

Excel-Quickie Nr. 48: Zelleninhalte unsichtbar machen

Und zum Schluß noch ein kleiner Trick aus der Formatierungs-Zauberkiste. Hier habe ich die Inhalt einer Zelle unsichtbar gemacht:

Zelleninhalt wird unsichtbar

Zelleninhalt wird unsichtbar

Und wie man an der Textfarbe oben in der Menüleiste erkennt, habe ich dabei nicht mit weißer Schrift gearbeitet. Der Trick ist ein benutzerdefiniertes Format, welches einfach aus drei Semikolons besteht:

Benutzerdefiniertes Format

Benutzerdefiniertes Format

Der Vorteil gegenüber der weißen Schrift ist, dass der Zelleninhalt auch dann noch unsichtbar bleibt, wenn die Hintergrundfarbe der Zelle geändert wird.

So, das war’s wieder für heute. Viel Spaß beim Ausprobieren!

Wenn dir der Artikel gefallen hat: Bitte weitersagen!

Das könnte dich auch interessieren:

Und immer daran denken: Excel beißt nicht!

P.S. Die Lösung ist immer einfach. Man muss sie nur finden.
(Alexander Solschenizyn)

P.P.S. Das Problem sitzt meistens vor dem Computer.



Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

7 Gedanken zu “Excel-Quickies (Vol 12)

  • Ernst

    Hallo Martin,

    ich verwende zum Runden auf eine Viertelstunde folgende Version.

    =RUNDEN(A1*“00:15:00″;0)/“00:15:00″

    =RUNDEN(A1*“00:10:00″;0)/“00:10:00″ runde auf volle 10 Minuten.

    Ernst

    • Martin Weiß Autor des Beitrags

      Hallo Ernst,

      ich habe Deine Version gerade bei mir ausprobiert, bekomme als Ergebnis aber immer 0:
      Gerundet

      Zur Sicherheit habe ich das Ergebnis in den Nachbarspalten noch unterschiedlich formatiert, aber es war immer Null.

      Stehe ich gerade irgendwo gewaltig auf dem Schlauch?

      Grüße,
      Martin

  • Wilhelm V.

    Hallo Martin,
    in Nr. 46 hat derFehlerteufel die Umschalttaste in Text und Grafik verschluckt.
    [Strg] + [Shift] + [Enter]
    Freundliche Grüße, Wilhelm

  • Jürgen Hager

    Hallo Martin,

    ich bin über die Matrixformeln auf Deine Seite gelangt und kämpfe mich z.Z. durch deine Excel-Quickies.

    Dein Quickie Nr. 47 kann ich gut nachvollziehen.
    Die Antwort von Ernst 13. Juli 2015 um 8:01 führt bei Dir immer zu „0“.
    Du sagst, dass Du auf dem Schlauch stehst.
    Da sich in der Formeln von Ernst ein Fehler eingeschlichen hat ist das Ergebnis nachvollziehbar

    Hier meine Erklärung:
    B C D E F
    3 Zeit Anzahl der 1/4 Std. in Zeit Anzahl der 1/4 Std 1/4 Std auf 1/1 Std Std Anzeige
    4 auf 0 Stellen gerundet umgerechnet Excel
    5 =B6*96 =RUNDEN(C6;0) =D6/96 =E6
    6 10:06 40,40 40,00 0,416666667 10:00
    7
    8 Vorschlag Ernst:
    9 =RUNDEN(B6*“00:15:00″;0)/“00:15:00″
    10 0 Dies ist richtig, weil sich in der Formel ein Fehler eingeschlichen hat.
    11 =RUNDEN(B10/“00:15:00″;0)*“00:15:00″ Dies wäre korrekt
    12 10:00:00
    13 =B6/“00:15:00″ =RUNDEN(C14;0) =D14*“00:15:00″ =E14
    14 40,40 40,00 0,416666667 10:00

    00:15 1/96
    0,010416667 0,010416667 Deswegen ist das vertauschen der Rechenzeichen notwendig

    Ich hoffe, dass das Beispiel nachvollziehbar ist.

    Deine Hinweise Pingback: Runden für Fortgeschrittene | Der Tabellen-Experte finde ich klasse

    Gruß
    Jürgen Hager

    • Martin Weiß Autor des Beitrags

      Hallo Jürgen,

      vielen Dank für die Erklärung und die Mühe, die du dir damit gemacht hast. Jetzt wird auch ein Schuh draus 🙂
      Und freut mich, wenn dir der Artikel zu den Rundungsfunktionen gefallen hat!

      Schöne Grüße,
      Martin