Excel-Quickies im November 2

Ein paar schnelle Excel-Tipps für zwischendurch
 

Gerade Anwender, die nicht so oft mit einer Tabellenkalkulation zu tun haben, sitzen manchmal auch bei kleineren Problemen frustriert vor Excel und denken “Das muss doch irgendwie gehen!”

Aber keine Angst: Auch diejenigen, die sich schon länger mit Excel beschäftigen, haben hin und wieder solche Momente 😉

Frei nach dem Motto “Wenn ich das nur gewusst hätte…” zeige ich dir mit den heutigen Excel-Quickies folgende kleinen Tricks:

  • Den kleinsten Wert außer Null finden
  • Datenüberprüfung kopieren
  • Kommentare ausdrucken

Ich bin sicher, da ist auch für dich etwas dabei!

Excel-Quickie Nr. 1: Der kleinste Wert außer Null

Dass man den kleinsten Wert einer Liste mit der MIN-Funktion berechnen kann, ist für dich wahrscheinlich keine neue Erkenntnis:

Die MIN-Funktion

Die MIN-Funktion

Wie man im Bild oben sieht, wird die leere Zelle richtigerweise ignoriert. Anders sieht es aus, wenn statt der leeren Zelle der Wert Null in der Liste enthalten ist. In diesem Fall ermittelt die MIN-Funktion immer 0 als kleinsten Wert:

... nicht immer das gewünschte Ergebnis

… nicht immer das gewünschte Ergebnis

Dies ist aber nicht in jedem Fall erwünscht. Was macht man nun, wenn man den kleinsten Wert mit Ausnahme von Null finden will? Die MIN-Funktion hilft offensichtlich nicht weiter. Eine Kombination aus den Funktionen KGRÖSSTE und ZÄHLENWENN bringt aber die Lösung:

Kombination KGRÖSSTE und ZÄHLENWENN

Kombination KGRÖSSTE und ZÄHLENWENN

Zur Erinnerung: Die Funktion ermittelt eben den k-größten Wert in einer Liste:
=KGRÖSSTE(Liste; k)
Also z.B. für k = 2 den zweitgrößten, für k = 3 den drittgrößten Wert usw.

Die ZÄHLENWENN-Funktion hingegen ermittelt die Anzahl der Werte, die dem Suchkriterium entsprechen:
=ZÄHLENWENN(Bereich; Suchkriterium)
=ZÄHLENWENN(B1:B8;">0")

In unserem Beispiel enthält die Liste 7 Zahlen, die größer Null sind. Eingesetzt in unsere KGRÖSSTE-Funktion wird so der 7.-grösste Wert berechnet – und damit der kleinste Wert außer Null!

Ergänzung:
Gleich zwei Leser haben mich auf eine wichtige Ergänzung hingewiesen (vielen Dank an Johanna und Peter): Wenn die Liste negative Werte enhält, funktioniert die Lösung mit der KGRÖSSTE-Funktion nicht. Stattdessen könnte man folgende Array-Formel einsetzen:
{=MIN(WENN(B1:B8<>0;B1:B8))}
Die geschweiften Klammern dürfen dabei nicht von Hand eingegeben werden. Stattdessen wird die Formel mit STRG+Umschalt+Enter abgeschlossen.

Oder man bleibt einfach bei der normalen MIN-Funktion:

Minimum mit negativen Zahlen

Minimum mit negativen Zahlen

😉

Excel-Quickie Nr. 2: Datenüberprüfung kopieren

Angenommen, du hast in deiner Tabelle für eine oder mehrere Zellen mit Hilfe der Datenüberprüfung eine Gültigkeitsregel definiert. In meinem Beispiel habe ich in der ersten Tabelle eine Dropdown-Liste für die Eingabe der Produkte festgelegt:

Datenüberprüfung nur in Tabelle 1

Datenüberprüfung nur in Tabelle 1

Leider fällt mir erst hinter auf, dass ich die gleiche Auswahlliste auch in den beiden anderen Tabellen bräuchte. Das Kopieren des Zellbereichs B4:B11 und Einfügen in den Zielbereichen E4:E11 bzw. H4:H11 wäre zwar möglich. Damit hätte ich automatisch auch meine Dropdown-Listen kopiert. Leider überschreibe ich damit aber auch das Zielformat:

Einfügen zerstört das Zielformat

Einfügen zerstört das Zielformat

Die Lösung ist aber einfach und führt über die rechte Maustaste: Nach dem Kopieren der Quellfelder B4:B11 wähle ich im Zielbereich mit der rechten Maustaste den Punkt “Inhalte einfügen”. Hier gibt es den Punkt “Gültigkeit”:

Inhalte einfügen - Gültigkeit

Inhalte einfügen – Gültigkeit

Und somit werden nur die Gültigkeitsregeln aus der Datenüberprüfung übernommen, während meine sonstigen Formate erhalten bleiben:

Nur die Datenüberprüfung wurde eingefügt

Nur die Datenüberprüfung wurde eingefügt

Excel-Quickie Nr. 3: Kommentare ausdrucken

Ein praktischer Weg, bestimmte Zellinhalte mit wichtigen Hinweisen zu versehen, ist die Kommentar-Funktion. Die Kommentare werden standardmäßig nur mit einem kleinen roten Punkt gekennzeichnet und erscheinen automatisch, sobald man die Maus über die entsprechende Zelle bewegt:

Kommentare

Kommentare

Wie bringt man diese Kommentare jedoch beim Ausdrucken der Tabelle auf’s Papier? Es gibt zwei Möglichkeiten:

Möglichkeit 1: Kommentare so wie in der Tabelle angezeigt ausdrucken
Dazu blende ich die Kommentare zuerst ein und bringe sie mit der Maus ggf. in die gewünschte Position:

Alle Kommentare einblenden

Alle Kommentare einblenden

Im Fenster “Seite einrichten” wähle ich dann in der Registerkarte “Blatt” im Feld “Kommentare” die Option “Wie auf dem Blatt angezeigt” aus:

Option 1: Drucken wie angezeigt

Option 1: Drucken wie angezeigt

Wie man in der Seitenansicht sieht, werden die Kommentare genauso wie in der Tabelle dargestellt auch auf dem Ausdruck angeordnet:

Druckvorschau

Druckvorschau

Möglichkeit 2: Kommentare gesammelt am Ende ausdrucken
Hier wähle ich im Fenster “Seite einrichten” stattdessen die Option “Am Ende des Blattes” aus:

Option 2: Am Ende des Blattes

Option 2: Am Ende des Blattes

Die eigentliche Tabelle wird dabei unverändert gedruckt und sämtliche Kommentare erscheinen auf einem separaten Blatt unter Angabe des Zellbezuges fein säuberlich aufgelistet:

Alle Kommentare separat gelistet

Alle Kommentare separat gelistet


So, das war’s wieder für heute. Viel Spaß beim Ausprobieren!

 

Das könnte dich auch interessieren:

Und immer daran denken: Excel beißt nicht!

P.S. Die Lösung ist immer einfach. Man muss sie nur finden.
(Alexander Solschenizyn)

P.P.S. Das Problem sitzt meistens vor dem Computer.



Kommentar erstellen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

2 Gedanken zu “Excel-Quickies im November

  • Felix Kappl

    Es ist nun mal an der Zeit mich bei dir für deinen Newsletter zu bedanken. Ich lese Sie immer mit großen Interresse. Oft sind es die kleinigkeiten oder deine Tipps die mir das tägliche Arbeiten mit Excel erleichtern. Weiter so….

    Felix Kappl

    • Martin Weiß Beitragsautor

      Hallo Felix,

      vielen Dank für das nette Feedback, das freut mich wirklich sehr (und motiviert natürlich!)

      Schöne Grüße,
      Martin